Minigame Madness - Server orchestrator is back up – Incident details
All systems operational
Can't connect even though all systems are online and have rebooted Steam? Your ISP or router settings might be blocking the game. In such cases, we suggest using a VPN. Feel free to join our Discord for help!
Server orchestrator is back up
Resolved
Major outage
Started 1 day agoSeptember 08, 2026Lasted 28 minutesSeptember 08, 202609:21:2609:49:34UTC
Affected
Game
Major outage from 9:21 AM to 9:49 AM
Server orchestrator
Major outage from 9:21 AM to 9:49 AM
Updates
Resolved
UTC
Resolved
UTC
Server orchestrator is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
UTC
Investigating
UTC
Server orchestrator is down at the moment. This incident was automatically created by Instatus monitoring.